13th September 2017

ISP Network Network issues

We currently see increased latency and intermittent network connectivity issues

Update 14:55

As of now the network issues seem to be resolved. We'll keep monitoring.

Update 15:01

We still see some occasional packet loss. We'll keep monitoring.

Update 15:25

Situation seems stable since 15:02. We'll keep monitoring.