28th April 2020

Update of Let's Encrypt Integration, scheduled 1 year ago

Update of Let's Encrypt Integration

Dear APPUiO users,

We will update the Let's Encrypt integration of APPUiO. The new version comes with many improvements and bugfixes. The basic functionality stays the same: By setting the kubernetes.io/tls-acme=true annotation on a Route object, a Let's Encrypt certificate will be provisioned and configured.

One small breaking change is to be expected: While the current version automatically creates a secret containing the TLS certificate and key, the new version only creates such a secret if the annotation acme.openshift.io/secret-name is set to a valid name. During the upgrade we will set this annotation on all existing routes in order to maintain the already existing secrets.

You can find a more detailed documentation here.

We will do the update in the coming month. You can already set the mentioned annotation since the current version just ignores it.

What does this mean for me? If you actively use the secret that's being created with the TLS certificate and key, you need to set the annotation acme.openshift.io/secret-name=mysecretname on your Route object. If you're not using this secret, nothing will change and you don't have to do any further steps.

Best regards, your VSHN team