7th November 2019

cloudscale.ch Network connectivity degraded

Our Cloudprovider is currently having issues with their network and is working on it. We will keep you updated.

See https://cloudscale-status.net/incident/78 for more infos.


UPDATE 16:00: Network has stabilized, we're observing now.


UPDATE 16:27: The situation is stable again. If you experience any issues feel free to reach out to us!